Gtkmm version problems

From LSDevLinux
Revision as of 10:35, 24 November 2010 by Mayhewn (talk | contribs) (Reverted edits by Okopacare (Talk); changed back to last version by LSDevManager)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

gtkmm does not contain Gdk::Window.create_cairo_context before version 2.9 (Despite its mention in the tutorial that comes with version 2.4)

Solution to this issue

As Brent is already using GTK+ 2.10, I plan on upgrading to GTK+ 2.10, gtkmm 2.10 and the corresponding Cairo / Cairomm. Note that gtkmm versions are not always what they seem, the 2.4 package in Debian actually provides gtkmm2.8.

After the download, the following needs to be run:

./autogen.sh --prefix=/usr/local (or /opt)
make
make install (?)