FieldWorks Installation Instructions

From LSDevLinux
Revision as of 13:15, 27 May 2010 by Mayhewn (talk | contribs) (Intalling FieldWorks: Insert real instructions)

Jump to: navigation, search

These are instructions for installing and testing FieldWorks on Linux.

We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings go to:

System -> Preferences -> Appearance and click on the Visual Effects tab. Choose Normal.

Installing FieldWorks

Using your browser of choice, go to:

http://packages.sil.org/

and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see packages.sil.org in the Origin tab on the left-hand side of the Synaptic Package Manager, or in Ubuntu Software Center.

Go back to Software Sources and edit the entry for packages.sil.org. Change the Components field to read main experimental. Close the window and allow the reload to take place.

You should see the following packages available in Synaptic or Software Center:

  • fieldworks
  • fieldworks-mono
  • fieldworks-libgdiplus

Selecting fieldworks for installation should automatically select the other two as well. Proceed with the installation in the normal way.

Preparing FieldWorks

For testing purposes, some sample data has been provided. To use this data, it needs to be copied to your home area. You can use either Nautilus or a terminal to set up data to use for testing:

For Nautilus:

click on Places -> Computer
Nagivate to File System -> usr -> share -> FieldWorks -> ReleaseData and find the file Sena2.xml and Sena3.xml
Select them both
Right Click on the files and copy them
Navigate to your home folder (username)
Click on Edit -> Paste

Using a terminal:

Applications -> Accessories -> Terminal
$ cp /usr/share/FieldWorks/ReleaseData/Sena3.xml ~

Run FieldWorks

To run either Translation Editor (TE) or Language Explorer (Flex) go to:

Applications -> Education -> click on either the TE or Flex icon
In the next dialog click Open an existing Project
Navigate to your home folder (Personal) and click on Sena2.xml or Sena3.xml

TE or Flex should now open with the data you selected. The next time you run the application it will open with this same data.

Using Help

To run the Demo Movies in the Flex Help menu you need the Adobe Flash plugin. To check for this go to:

System -> Synaptic Package Manager
Go to adobe-flashplugin
If it is not already installed, click on the box and choose Mark for Installation
At the top click Apply

After the installation completes you should now be able to play the demo movies in the Flex Help. If, after you run the Demo Movies, your FireFox becomes unresponsive:

Open a Terminal (Applications -> Accessories -> Terminal)
$ killall firefox

This should close down all instances of FireFox running so that you can use it again.