Difference between revisions of "FieldWorks Installation Instructions"

From LSDevLinux
Jump to: navigation, search
m (Reverted edits by Okopacare (Talk); changed back to last version by Newlands)
Line 1: Line 1:
=[http://otyxemydu.co.cc This Page Is Currently Under Construction And Will Be Available Shortly, Please Visit Reserve Copy Page]=
 
 
These are instructions for installing and testing FieldWorks on Linux.
 
These are instructions for installing and testing FieldWorks on Linux.
  
 
__TOC__
 
__TOC__
  
<span style="color:#990000;font-size:160%;font-weight:bold">Warning:</span> If you choose to use the software you need to understand that it probably will crash from time to time, maybe even frequently, and that there are no guarantees it won’t scramble your data. Also, we'd like you to commit to working with us by providing full information about what you find and by trying out any fixes or workarounds that we might ask you to check for us.
+
<span style="color:#990000;font-size:160%;font-weight:bold">Warning:</span> If you choose to use the software you need to understand that it probably will crash from time to time, maybe even frequently, and that there are no guarantees it won’t scramble your data. Also, we'd like you to commit to working with us by providing full information about what you find and by trying out any fixes or workarounds that we might ask you to check for us.
  
 
For further background information on this release, please read the [http://linux.lsdev.sil.org/blog/?p=67 announcement] in the blog.
 
For further background information on this release, please read the [http://linux.lsdev.sil.org/blog/?p=67 announcement] in the blog.
Line 12: Line 11:
 
This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) and Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these. Also see the section on [[#Keyboarding_in_FieldWorks|Keyboarding in FieldWorks]] below.
 
This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) and Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these. Also see the section on [[#Keyboarding_in_FieldWorks|Keyboarding in FieldWorks]] below.
  
We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose '''System''' &gt; '''Preferences''' &gt; '''Appearance'''. Click the '''Visual Effects''' tab. Click '''Normal'''. FieldWorks will run without compiz for those who can not get compiz turned on for some reason, but expect your screen performance to deteriorate as a result.
+
We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose '''System''' > '''Preferences''' > '''Appearance'''. Click the '''Visual Effects''' tab. Click '''Normal'''. FieldWorks will run without compiz for those who can not get compiz turned on for some reason, but expect your screen performance to deteriorate as a result.
  
 
==Install all Updates==
 
==Install all Updates==
  
 
Before you begin testing or using FieldWorks on Linux, you will need to install all updates for you system. You can do this by:
 
Before you begin testing or using FieldWorks on Linux, you will need to install all updates for you system. You can do this by:
# Going to '''System''' &gt; '''Administration''' &gt; '''Update Manager''', enter your password if required.
+
# Going to '''System''' > '''Administration''' > '''Update Manager''', enter your password if required.
 
# Once the Update Manager is running it may already be showing a list of things ready for updating, but go ahead and click '''Check''' to get the latest list.
 
# Once the Update Manager is running it may already be showing a list of things ready for updating, but go ahead and click '''Check''' to get the latest list.
 
# Now click '''Install Updates''' and wait for those steps to complete.
 
# Now click '''Install Updates''' and wait for those steps to complete.
Line 25: Line 24:
  
 
If you are behind a '''proxy''' and do not already have the ttf-mscorefonts-installer package installed, then please follow these steps so that the mscorefonts package will install correctly.
 
If you are behind a '''proxy''' and do not already have the ttf-mscorefonts-installer package installed, then please follow these steps so that the mscorefonts package will install correctly.
# Open your favorite text editor, for instance use Applications -&gt; Accessories -&gt; gedit Text Editor
+
# Open your favorite text editor, for instance use Applications -> Accessories -> gedit Text Editor
 
# Copy the following 2 lines and paste them in your empty document:
 
# Copy the following 2 lines and paste them in your empty document:
#:&lt;code&gt;&lt;nowiki&gt;http_proxy = http://proxy.yourdomain.com:3128&lt;/nowiki&gt;&lt;/code&gt;
+
#:<code><nowiki>http_proxy = http://proxy.yourdomain.com:3128</nowiki></code>
#:&lt;code&gt;use_proxy = on&lt;/code&gt;
+
#:<code>use_proxy = on</code>
 
# Correct the proxy to match your information, including using the correct port number.
 
# Correct the proxy to match your information, including using the correct port number.
# Use File -&gt; Save As
+
# Use File -> Save As
# Be sure you are in your home folder and give the file a name of &lt;code&gt;.wgetrc&lt;/code&gt;
+
# Be sure you are in your home folder and give the file a name of <code>.wgetrc</code>
  
 
Continue with the following steps to install FieldWorks.
 
Continue with the following steps to install FieldWorks.
Line 41: Line 40:
 
:http://packages.sil.org/
 
:http://packages.sil.org/
  
and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see &lt;code&gt;packages.sil.org&lt;/code&gt; in the '''Origin''' tab on the left-hand side of the Synaptic Package Manager.
+
and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see <code>packages.sil.org</code> in the '''Origin''' tab on the left-hand side of the Synaptic Package Manager.
  
Go back to Software Sources and make an additional entry for &lt;code&gt;packages.sil.org&lt;/code&gt;, but this time when changing the distro name add &lt;code&gt;-experimental&lt;/code&gt; to the end of the name. For example, if you are currently using &lt;code&gt;lucid main&lt;/code&gt; use &lt;code&gt;lucid-experimental main&lt;/code&gt;. (You don't need to add the key again.) Close the window and click the reload button.
+
Go back to Software Sources and make an additional entry for <code>packages.sil.org</code>, but this time when changing the distro name add <code>-experimental</code> to the end of the name. For example, if you are currently using <code>lucid main</code> use <code>lucid-experimental main</code>. (You don't need to add the key again.) Close the window and click the reload button.
  
You should now see the following packages under &lt;code&gt;packages.sil.org&lt;/code&gt; in Synaptic's ''Origin'' view:
+
You should now see the following packages under <code>packages.sil.org</code> in Synaptic's ''Origin'' view:
  
 
* fieldworks
 
* fieldworks
Line 51: Line 50:
 
* fieldworks-libgdiplus
 
* fieldworks-libgdiplus
  
Selecting &lt;code&gt;fieldworks&lt;/code&gt; for installation should automatically select the other two as well, and any other needed dependencies. Proceed with the installation in the normal way.
+
Selecting <code>fieldworks</code> for installation should automatically select the other two as well, and any other needed dependencies. Proceed with the installation in the normal way.
  
 
==Preparing FieldWorks==
 
==Preparing FieldWorks==
Line 57: Line 56:
  
 
Copying data using Nautilus:
 
Copying data using Nautilus:
# Choose '''Places''' &gt; '''Computer'''.
+
# Choose '''Places''' > '''Computer'''.
# Nagivate to '''File System''' &gt; '''usr''' &gt; '''share''' &gt; '''fieldworks''' &gt; '''ReleaseData'''.
+
# Nagivate to '''File System''' > '''usr''' > '''share''' > '''fieldworks''' > '''ReleaseData'''.
 
# Then Select the '''Sena 2''' folder
 
# Then Select the '''Sena 2''' folder
# Choose '''Edit''' &gt; '''Copy'''.
+
# Choose '''Edit''' > '''Copy'''.
# Choose '''Go''' &gt; '''Home Folder'''.
+
# Choose '''Go''' > '''Home Folder'''.
# Choose '''Edit''' &gt; '''Paste'''.
+
# Choose '''Edit''' > '''Paste'''.
 
# Repeat these steps choosing the '''Sena 3''' folder.
 
# Repeat these steps choosing the '''Sena 3''' folder.
  
 
==Run FieldWorks==
 
==Run FieldWorks==
 
To run either Translation Editor (TE) or Language Explorer (Flex), do the following:
 
To run either Translation Editor (TE) or Language Explorer (Flex), do the following:
# Choose '''Applications''' &gt; '''Education''' &gt; '''FieldWorks Translation Editor''' or '''FieldWorks Language Explorer'''.
+
# Choose '''Applications''' > '''Education''' > '''FieldWorks Translation Editor''' or '''FieldWorks Language Explorer'''.
 
# On the dialog, click '''Open an existing Project'''.
 
# On the dialog, click '''Open an existing Project'''.
 
# Navigate to your home folder (Personal) and click Sena 2.fwdata or Sena 3.fwdata.
 
# Navigate to your home folder (Personal) and click Sena 2.fwdata or Sena 3.fwdata.
Line 82: Line 81:
  
 
To enable the partner repository:
 
To enable the partner repository:
# Open '''Synaptic Package Manager''' and go to '''Settings''' &gt; '''Repositories''' and click on the '''Other Software''' tab.
+
# Open '''Synaptic Package Manager''' and go to '''Settings''' > '''Repositories''' and click on the '''Other Software''' tab.
 
# If the partner repository does not already show in the list, then click the '''Add''' button at the bottom.
 
# If the partner repository does not already show in the list, then click the '''Add''' button at the bottom.
 
# Copy this line and paste it into the APT line, changing the lucid to karmic if needed:
 
# Copy this line and paste it into the APT line, changing the lucid to karmic if needed:
#:deb &lt;nowiki&gt;http://archive.canonical.com/&lt;/nowiki&gt; lucid partner
+
#:deb <nowiki>http://archive.canonical.com/</nowiki> lucid partner
 
# Now click '''Add Source''', then click '''Close''' and '''Reload'''.
 
# Now click '''Add Source''', then click '''Close''' and '''Reload'''.
  
 
To check for the adobe-flashplugin, do the following:
 
To check for the adobe-flashplugin, do the following:
 
# Using the '''Synaptic Package Manager''',
 
# Using the '''Synaptic Package Manager''',
# Choose '''Edit''' &gt; '''Search'''. In the '''Search''' box, type &lt;code&gt;adobe-flashplugin&lt;/code&gt; and click '''Search'''.
+
# Choose '''Edit''' > '''Search'''. In the '''Search''' box, type <code>adobe-flashplugin</code> and click '''Search'''.
 
# If it is not already installed, right-click the package and click '''Mark for Installation'''.
 
# If it is not already installed, right-click the package and click '''Mark for Installation'''.
 
# On the toolbar, click '''Apply'''.
 
# On the toolbar, click '''Apply'''.
 
After the installation completes you should now be able to play the demo movies in the Flex Help.
 
After the installation completes you should now be able to play the demo movies in the Flex Help.
If, after you run the Demo Movies, your Firefox becomes unresponsive, open a Terminal by choosing '''Applications''' &gt; '''Accessories''' &gt; '''Terminal''', and run &lt;code&gt;$ killall firefox&lt;/code&gt;
+
If, after you run the Demo Movies, your Firefox becomes unresponsive, open a Terminal by choosing '''Applications''' > '''Accessories''' > '''Terminal''', and run <code>$ killall firefox</code>
  
 
This should close down all instances of Firefox running so that you can use it again.
 
This should close down all instances of Firefox running so that you can use it again.
Line 106: Line 105:
 
If you have previously used the alpha3, alpha4 or alpha5 FieldWorks package, it may be necessary to get rid of some configuration files before alpha7 will run correctly. So once you have followed the above directions, downloaded and installed the alpha7 package and tried to run either Translation Editor or Language Explorer, you may get an error when opening the sample projects. Follow these steps to correct this error.
 
If you have previously used the alpha3, alpha4 or alpha5 FieldWorks package, it may be necessary to get rid of some configuration files before alpha7 will run correctly. So once you have followed the above directions, downloaded and installed the alpha7 package and tried to run either Translation Editor or Language Explorer, you may get an error when opening the sample projects. Follow these steps to correct this error.
  
# Choose '''Places''' &gt; '''Home Folder'''.
+
# Choose '''Places''' > '''Home Folder'''.
 
# On the '''View''' menu, select '''Show Hidden Files'''.
 
# On the '''View''' menu, select '''Show Hidden Files'''.
# Scroll down to &lt;code&gt;.config&lt;/code&gt;, open it and if there is a &lt;code&gt;fieldworks&lt;/code&gt; folder there delete it.
+
# Scroll down to <code>.config</code>, open it and if there is a <code>fieldworks</code> folder there delete it.
# Choose '''Go''' &gt; '''Home Folder'''. Scroll to &lt;code&gt;.mono&lt;/code&gt; open it and if there is a &lt;code&gt;registry&lt;/code&gt; folder there delete it.
+
# Choose '''Go''' > '''Home Folder'''. Scroll to <code>.mono</code> open it and if there is a <code>registry</code> folder there delete it.
 
# On the '''View''' menu, clear '''Show Hidden Files'''.
 
# On the '''View''' menu, clear '''Show Hidden Files'''.
 
# Try to run TE or Flex again and one of the sample projects should open correctly this time.
 
# Try to run TE or Flex again and one of the sample projects should open correctly this time.

Revision as of 10:36, 24 November 2010

These are instructions for installing and testing FieldWorks on Linux.

Warning: If you choose to use the software you need to understand that it probably will crash from time to time, maybe even frequently, and that there are no guarantees it won’t scramble your data. Also, we'd like you to commit to working with us by providing full information about what you find and by trying out any fixes or workarounds that we might ask you to check for us.

For further background information on this release, please read the announcement in the blog.

Introduction

This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) and Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these. Also see the section on Keyboarding in FieldWorks below.

We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose System > Preferences > Appearance. Click the Visual Effects tab. Click Normal. FieldWorks will run without compiz for those who can not get compiz turned on for some reason, but expect your screen performance to deteriorate as a result.

Install all Updates

Before you begin testing or using FieldWorks on Linux, you will need to install all updates for you system. You can do this by:

  1. Going to System > Administration > Update Manager, enter your password if required.
  2. Once the Update Manager is running it may already be showing a list of things ready for updating, but go ahead and click Check to get the latest list.
  3. Now click Install Updates and wait for those steps to complete.
  4. Restart the computer if requested to do so.

Preparing to install MSCoreFonts

If you are behind a proxy and do not already have the ttf-mscorefonts-installer package installed, then please follow these steps so that the mscorefonts package will install correctly.

  1. Open your favorite text editor, for instance use Applications -> Accessories -> gedit Text Editor
  2. Copy the following 2 lines and paste them in your empty document:
    http_proxy = http://proxy.yourdomain.com:3128
    use_proxy = on
  3. Correct the proxy to match your information, including using the correct port number.
  4. Use File -> Save As
  5. Be sure you are in your home folder and give the file a name of .wgetrc

Continue with the following steps to install FieldWorks.

Installing FieldWorks

Using your browser of choice, go to:

http://packages.sil.org/

and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see packages.sil.org in the Origin tab on the left-hand side of the Synaptic Package Manager.

Go back to Software Sources and make an additional entry for packages.sil.org, but this time when changing the distro name add -experimental to the end of the name. For example, if you are currently using lucid main use lucid-experimental main. (You don't need to add the key again.) Close the window and click the reload button.

You should now see the following packages under packages.sil.org in Synaptic's Origin view:

  • fieldworks
  • fieldworks-mono
  • fieldworks-libgdiplus

Selecting fieldworks for installation should automatically select the other two as well, and any other needed dependencies. Proceed with the installation in the normal way.

Preparing FieldWorks

For testing purposes, some sample data has been provided. Please use this sample data for Alpha testing. Importing your own data is not encouraged during Alpha testing. To use this data, it needs to be copied to your home area.

Copying data using Nautilus:

  1. Choose Places > Computer.
  2. Nagivate to File System > usr > share > fieldworks > ReleaseData.
  3. Then Select the Sena 2 folder
  4. Choose Edit > Copy.
  5. Choose Go > Home Folder.
  6. Choose Edit > Paste.
  7. Repeat these steps choosing the Sena 3 folder.

Run FieldWorks

To run either Translation Editor (TE) or Language Explorer (Flex), do the following:

  1. Choose Applications > Education > FieldWorks Translation Editor or FieldWorks Language Explorer.
  2. On the dialog, click Open an existing Project.
  3. Navigate to your home folder (Personal) and click Sena 2.fwdata or Sena 3.fwdata.

TE or Flex should now open with the data you selected. The next time you run the application it will open with this same data.

You may notice some display problems with text in drop down lists or dialog boxes. If so you can try removing a specific font and see if there is an improvement. This font is the ttf-thai-tlwg. To remove this font, you can use Synaptic, navigate to this font and choose to mark for removal.

Using Help

The help files in Flex should now be usuable as of Alpha7, but the TE help files will give an error.

The student manuals should open successfully in OpenOffice.

To run the Demo Movies in the Flex Help menu you need the Adobe Flash plugin. To get this the partner repository must be enabled.

To enable the partner repository:

  1. Open Synaptic Package Manager and go to Settings > Repositories and click on the Other Software tab.
  2. If the partner repository does not already show in the list, then click the Add button at the bottom.
  3. Copy this line and paste it into the APT line, changing the lucid to karmic if needed:
    deb http://archive.canonical.com/ lucid partner
  4. Now click Add Source, then click Close and Reload.

To check for the adobe-flashplugin, do the following:

  1. Using the Synaptic Package Manager,
  2. Choose Edit > Search. In the Search box, type adobe-flashplugin and click Search.
  3. If it is not already installed, right-click the package and click Mark for Installation.
  4. On the toolbar, click Apply.

After the installation completes you should now be able to play the demo movies in the Flex Help. If, after you run the Demo Movies, your Firefox becomes unresponsive, open a Terminal by choosing Applications > Accessories > Terminal, and run $ killall firefox

This should close down all instances of Firefox running so that you can use it again.

Keyboarding in FieldWorks

Keyboarding for FieldWorks is designed to use IBus, which is what is used in Ubuntu 9.10 and Ubuntu 10.04. Scim will not work for FieldWorks. A KMFL package for IBus is available from packages.sil.org for Ubuntu Lucid. There will be a package available for Ubuntu Kamic also but this has not been posted yet since that version of IBus will also need some patches. IBus comes with many language keyboard options available.

Getting rid of alpha3/alpha4/alpha5/alpha6 configurations

If you have previously used the alpha3, alpha4 or alpha5 FieldWorks package, it may be necessary to get rid of some configuration files before alpha7 will run correctly. So once you have followed the above directions, downloaded and installed the alpha7 package and tried to run either Translation Editor or Language Explorer, you may get an error when opening the sample projects. Follow these steps to correct this error.

  1. Choose Places > Home Folder.
  2. On the View menu, select Show Hidden Files.
  3. Scroll down to .config, open it and if there is a fieldworks folder there delete it.
  4. Choose Go > Home Folder. Scroll to .mono open it and if there is a registry folder there delete it.
  5. On the View menu, clear Show Hidden Files.
  6. Try to run TE or Flex again and one of the sample projects should open correctly this time.

Reporting Bugs

To report bugs, please use our Bugzilla database.

  1. If not already registered, click the New Account button at the top of the main page.
  2. If not already logged in, log in using the link and fields at the top of the page.
  3. Check whether an identical or similar bug has been reported, by doing one of the following:
    • Click FieldWorks at the bottom of the page to browse all outstanding bugs.
    • Click Search, select FieldWorks from the Product drop-down and enter some words to search for.
  4. Submit your information, by doing one of the following:
    • Add a comment to an existing bug, if appropriate:
      1. Type some text into the Additional Comments box
      2. Click Commit
    • File a new bug:
      1. Click New at the top of the page.
      2. Click FieldWorks.
      3. Fill out as much information as you can and click Commit.

Please note that the email address that you register with will be displayed on the web site and therefore will be publicly visible.