Difference between revisions of "FieldWorks Installation Instructions"

From LSDevLinux
Jump to: navigation, search
(Run FieldWorks)
(Add warning)
Line 1: Line 1:
 
These are instructions for installing and testing FieldWorks on Linux.
 
These are instructions for installing and testing FieldWorks on Linux.
 +
 
__TOC__
 
__TOC__
  
We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose '''System''' > '''Preferences''' > '''Appearance'''. Click the '''Visual Effects''' tab. Click '''Normal'''.
+
<span style="color:#990000;font-size:160%;font-weight:bold">Warning:</span> If you choose to use the software you need to understand that it probably will crash from time to time, maybe even frequently, and that there are no guarantees it won’t scramble your data. Also, we'd like you to commit to working with us by providing full information about what you find and by trying out any fixes or workarounds that we might ask you to check for us.
 +
 
 +
For further background information on this release, please the [http://linux.lsdev.sil.org/blog/?p=67 announcement] in the blog.
 +
 
 +
== Introduction ==
  
 
This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) but should work for Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these.
 
This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) but should work for Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these.
 +
 +
We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose '''System''' > '''Preferences''' > '''Appearance'''. Click the '''Visual Effects''' tab. Click '''Normal'''.
  
 
==Install all Updates==
 
==Install all Updates==

Revision as of 14:23, 19 July 2010

These are instructions for installing and testing FieldWorks on Linux.

Warning: If you choose to use the software you need to understand that it probably will crash from time to time, maybe even frequently, and that there are no guarantees it won’t scramble your data. Also, we'd like you to commit to working with us by providing full information about what you find and by trying out any fixes or workarounds that we might ask you to check for us.

For further background information on this release, please the announcement in the blog.

Introduction

This version of FieldWorks has been tested using Ubuntu 10.04 LTS (Lucid) but should work for Ubuntu 9.10 (Karmic). It may also work for other distros but has not been tested for these.

We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose System > Preferences > Appearance. Click the Visual Effects tab. Click Normal.

Install all Updates

Before you begin testing or using FieldWorks on Linux, you will need to install all updates for you system. You can do this by:

  1. Going to System > Administration > Update Manager, enter your password if required.
  2. Once the Update Manager is running it may already be showing a list of things ready for updating, but go ahead and click Check to get the latest list.
  3. Now click Install Updates and wait for those steps to complete.
  4. Restart the computer if requested to do so.

Preparing to install MSCoreFonts

If you are behind a proxy and do not already have the ttf-mscorefonts-installer package installed, then please follow these steps so that the mscorefonts package will install correctly.

  1. Open your favorite text editor, for instance use Applications -> Accessories -> gedit Text Editor
  2. Copy the following 2 lines and paste them in your empty document:
    http_proxy = http://proxy.yourdomain.com:3128
    use_proxy = on
  3. Correct the proxy to match your information, including using the correct port number.
  4. Use File -> Save As
  5. Be sure you are in your home folder and give the file a name of .wgetrc

Continue with the following steps to install FieldWorks.

Installing FieldWorks

Using your browser of choice, go to:

http://packages.sil.org/

and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see packages.sil.org in the Origin tab on the left-hand side of the Synaptic Package Manager.

Go back to Software Sources and make an additional entry for packages.sil.org, but this time when changing the distro name add -experimental to the end of the name. For example, if you are currently using lucid main use lucid-experimental main. (You don't need to add the key again.) Close the window and click the reload button.

You should now see the following packages under packages.sil.org in Synaptic's Origin view:

  • fieldworks
  • fieldworks-mono
  • fieldworks-libgdiplus

Selecting fieldworks for installation should automatically select the other two as well, and any other needed dependencies. Proceed with the installation in the normal way.

Preparing FieldWorks

For testing purposes, some sample data has been provided. Please use this sample data for Alpha testing. Importing your own data is not encouraged during Alpha testing. To use this data, it needs to be copied to your home area.

Copying data using Nautilus:

  1. Choose Places > Computer.
  2. Nagivate to File System > usr > share > fieldworks > ReleaseData.
  3. Then navigate to the Sena 2 folder
  4. Select Sena 2.fwdata.
  5. Choose Edit > Copy.
  6. Choose Go > Home Folder.
  7. Choose Edit > Paste.
  8. Repeat these steps choosing the Sena 3 folder and then Sena 3.fwdata

Run FieldWorks

To run either Translation Editor (TE) or Language Explorer (Flex), do the following:

  1. Choose Applications > Education > FieldWorks Translation Editor or FieldWorks Language Explorer.
  2. On the dialog, click Open an existing Project.
  3. Navigate to your home folder (Personal) and click Sena 2.fwdata or Sena 3.fwdata.

TE or Flex should now open with the data you selected. The next time you run the application it will open with this same data.

Using Help

To run the Demo Movies in the Flex Help menu you need the Adobe Flash plugin. To get this the partner repository must be enabled.

To enable the partner repository:

  1. Open Synaptic Package Manager and go to Settings > Repositories and click on the Other Software tab.
  2. If the partner repository does not already show in the list, then click the Add button at the bottom.
  3. Copy this line and paste it into the APT line, changing the lucid to karmic if needed:
    deb http://archive.canonical.com/ lucid partner
  4. Now click Add Source, then click Close and Reload.

To check for the adobe-flashplugin, do the following:

  1. Using the Synaptic Package Manager,
  2. Choose Edit > Search. In the Search box, type adobe-flashplugin and click Search.
  3. If it is not already installed, right-click the package and click Mark for Installation.
  4. On the toolbar, click Apply.

After the installation completes you should now be able to play the demo movies in the Flex Help. If, after you run the Demo Movies, your Firefox becomes unresponsive, open a Terminal by choosing Applications > Accessories > Terminal, and run $ killall firefox

This should close down all instances of Firefox running so that you can use it again.

Keyboarding in FieldWorks

Keyboarding for FieldWorks is designed to use IBus, which is what is used in Ubuntu 9.10 and Ubuntu 10.04. Scim will not work for FieldWorks. A KMFL package for IBus is available from packages.sil.org for Ubuntu Lucid. There will be a package available for Ubuntu Kamic also but this has not been posted yet since that version of IBus will also need some patches. IBus comes with many language keyboard options available.

Getting rid of alpha3/alpha4 configurations

If you have previously used the alpha3 or alpha4 FieldWorks package, it may be necessary to get rid of some configuration files before alpha5 will run correctly. So once you have followed the above directions, downloaded and installed the alpha5 package and tried to run either Translation Editor or Language Explorer, you may get an error when opening the sample projects. Follow these steps to correct this error.

  1. Choose Places > Home Folder.
  2. On the View menu, select Show Hidden Files.
  3. Scroll down to .config, open it and if there is a fieldworks folder there delete it.
  4. Choose Go > Home Folder. Scroll to .mono and delete this entire folder.
  5. On the View menu, clear Show Hidden Files.
  6. Try to run TE or Flex again and one of the sample projects should open correctly this time.

Reporting Bugs

To report bugs, please use our Bugzilla database.

  1. If not already registered, click the New Account button at the top of the main page.
  2. If not already logged in, log in using the link and fields at the top of the page.
  3. Check whether an identical or similar bug has been reported, by doing one of the following:
    • Click FieldWorks at the bottom of the page to browse all outstanding bugs.
    • Click Search, select FieldWorks from the Product drop-down and enter some words to search for.
  4. Submit your information, by doing one of the following:
    • Add a comment to an existing bug, if appropriate:
      1. Type some text into the Additional Comments box
      2. Click Commit
    • File a new bug:
      1. Click New at the top of the page.
      2. Click FieldWorks.
      3. Fill out as much information as you can and click Commit.

Please note that the email address that you register with will be displayed on the web site and therefore will be publicly visible.