Difference between revisions of "FieldWorks Installation Instructions"

From LSDevLinux
Jump to: navigation, search
m (Add to FieldWorks category)
(Add Reporting Bugs section)
Line 59: Line 59:
  
 
This should close down all instances of Firefox running so that you can use it again.
 
This should close down all instances of Firefox running so that you can use it again.
 +
 +
== Reporting Bugs ==
 +
 +
To report bugs, please use our [http://linux.lsdev.sil.org/bugzilla/ Bugzilla database].
 +
 +
# If not already registered, click the New Account button at the top of the main page.
 +
# If not already logged in, log in using the link and fields at the top of the page.
 +
# Check whether an identical or similar bug has been reported, by doing one of the following:
 +
#* Click '''FieldWorks''' at the bottom of the page to browse all outstanding bugs.
 +
#* Click '''Search''', select ''FieldWorks'' from the '''Product''' drop-down and enter some words to search for.
 +
# Submit your information, by doing one of the following:
 +
#* Add a comment to an existing bug, if appropriate:
 +
#*# Type some text into the Additional Comments box
 +
#*# Click '''Commit'''
 +
#* File a new bug:
 +
#*# Click '''New''' at the top of the page.
 +
#*# Click '''FieldWorks'''.
 +
#*# Fill out as much information as you can and click '''Commit'''.
 +
 +
Please note that the email address that you register with will be displayed on the web site and will therefore be publicly visible.
  
 
[[Category:FieldWorks]]
 
[[Category:FieldWorks]]
 
[[Category:Testing]]
 
[[Category:Testing]]

Revision as of 18:12, 30 May 2010

These are instructions for installing and testing FieldWorks on Linux.

We urge you to run FieldWorks with Compiz turned on and set to normal. This gives much better screen performance when using FieldWorks. To check your settings, choose System > Preferences > Appearance. Click the Visual Effects tab. Click Normal.

Installing FieldWorks

Using your browser of choice, go to:

http://packages.sil.org/

and follow the instructions there for adding the SIL package repository to your list of software sources. Make sure that you can now see packages.sil.org in the Origin tab on the left-hand side of the Synaptic Package Manager.

Go back to Software Sources and make an additional entry for packages.sil.org, but this time when changing the distro name add -experimental to the end of the name. For example, if you are currently using lucid use lucid-experimental. (You don't need to add the key again.) Close the window and click the reload button.

You should now see the following packages under packages.sil.org in Synaptic's Origin view:

  • fieldworks
  • fieldworks-mono
  • fieldworks-libgdiplus

Selecting fieldworks for installation should automatically select the other two as well. Proceed with the installation in the normal way.

Preparing FieldWorks

For testing purposes, some sample data has been provided. Please use this sample data for Alpha testing. Importing your own data is not encouraged during Alpha testing. To use this data, it needs to be copied to your home area.

Copying data using Nautilus:

  1. Choose Places > Computer.
  2. Nagivate to File System > usr > share > fieldworks > ReleaseData.
  3. Select Sena 2.xml and Sena 3.xml.
  4. Choose Edit > Copy.
  5. Choose Go > Home Folder.
  6. Choose Edit > Paste.

Run FieldWorks

To run either Translation Editor (TE) or Language Explorer (Flex), do the following:

  1. Choose Applications > Education > FieldWorks Translation Editor or FieldWorks Language Explorer.
  2. On the dialog, click Open an existing Project.
  3. Navigate to your home folder (Personal) and click Sena 2.xml or Sena 3.xml.

TE or Flex should now open with the data you selected. The next time you run the application it will open with this same data.

Using Help

To run the Demo Movies in the Flex Help menu you need the Adobe Flash plugin. To get this the partner repository must be enabled.

To enable the partner repository:

  1. Open Synaptic Package Manager and go to Settings > Repositories and click on the Other Software tab.
  2. If the partner repository does not already show in the list, then click the Add button at the bottom.
  3. Copy this line and paste it into the APT line, changing the lucid to karmic if needed:
    deb http://archive.canonical.com/ lucid partner
  4. Now click Add Source, then click Close and Reload.

To check for the adobe-flashplugin, do the following:

  1. Using the Synaptic Package Manager,
  2. Choose Edit > Search. In the Search box, type adobe-flashplugin and click Search.
  3. If it is not already installed, right-click the package and click Mark for Installation.
  4. On the toolbar, click Apply.

After the installation completes you should now be able to play the demo movies in the Flex Help. If, after you run the Demo Movies, your Firefox becomes unresponsive, open a Terminal by choosing Applications > Accessories > Terminal, and run $ killall firefox

This should close down all instances of Firefox running so that you can use it again.

Reporting Bugs

To report bugs, please use our Bugzilla database.

  1. If not already registered, click the New Account button at the top of the main page.
  2. If not already logged in, log in using the link and fields at the top of the page.
  3. Check whether an identical or similar bug has been reported, by doing one of the following:
    • Click FieldWorks at the bottom of the page to browse all outstanding bugs.
    • Click Search, select FieldWorks from the Product drop-down and enter some words to search for.
  4. Submit your information, by doing one of the following:
    • Add a comment to an existing bug, if appropriate:
      1. Type some text into the Additional Comments box
      2. Click Commit
    • File a new bug:
      1. Click New at the top of the page.
      2. Click FieldWorks.
      3. Fill out as much information as you can and click Commit.

Please note that the email address that you register with will be displayed on the web site and will therefore be publicly visible.