Difference between revisions of "Build FieldWorks for Mac"

From LSDevLinux
Jump to: navigation, search
(Mono: Explain libLAPACK error and workaround)
(Prerequisites: Environment variables)
Line 12: Line 12:
 
* Install [http://www.macports.org/ MacPorts]
 
* Install [http://www.macports.org/ MacPorts]
 
* Install the [[Set up Perforce for FieldWorks|Perforce client software]]
 
* Install the [[Set up Perforce for FieldWorks|Perforce client software]]
 +
 +
For the MacPorts versions of libraries to be used instead of the built-in ones, several environment variables need to be set. This can be done in <code>~/.profile</code> (for use in Terminal) as follows:
 +
 +
export CPATH=/opt/local/include${CPATH+:}$CPATH
 +
export LIBRARY_PATH=/opt/local/lib${LIBRARY_PATH+:}$LIBRARY_PATH
 +
export DYLD_LIBRARY_PATH=/opt/local/lib${DYLD_LIBRARY_PATH+:}$DYLD_LIBRARY_PATH
 +
 +
It's also possible to set them in <code>~/.MacOSX/environment.plist</code>, making them applicable to all GUI programs, but this will cause the built-in Mac OS apps to use MacPorts libraries rather than the built-in ones they were developed with, which may not be desirable.
  
 
==Install and build dependencies==
 
==Install and build dependencies==

Revision as of 17:52, 29 March 2011

The port of FieldWorks to Mac is still at an early stage, although we are hopeful that almost all of the work done to port it to Linux will carry over to Mac with very little change.

This page documents the current state of our knowledge about the steps that need to be followed.

Prerequisites

We recommend that needed software packages be installed with MacPorts, whenever possible. This makes it much easier to keep things organized and updated. There is a wide range of ports available, and the versions are usually quite recent.

For the MacPorts versions of libraries to be used instead of the built-in ones, several environment variables need to be set. This can be done in ~/.profile (for use in Terminal) as follows:

export CPATH=/opt/local/include${CPATH+:}$CPATH
export LIBRARY_PATH=/opt/local/lib${LIBRARY_PATH+:}$LIBRARY_PATH
export DYLD_LIBRARY_PATH=/opt/local/lib${DYLD_LIBRARY_PATH+:}$DYLD_LIBRARY_PATH

It's also possible to set them in ~/.MacOSX/environment.plist, making them applicable to all GUI programs, but this will cause the built-in Mac OS apps to use MacPorts libraries rather than the built-in ones they were developed with, which may not be desirable.

Install and build dependencies

Install the following MacPorts packages:

  • autoconf autoconf-archive automake libtool
  • mono nant
  • ImageMagick +wmf +jbig +jpeg2
  • icu
  • gtkmm
  • enchant
  • ossp-uuid
  • pccts
  • quilt

Although some of the packages above (eg autoconf) are already installed on the OS, we typically need the MacPorts ones, which are newer, or are needed by add-ons like autoconf-archive.

There is a Mac-native version of GTK which can be installed by substituting the following lines:

  • sudo port install gtkmm +quartz +atsui +no_x11
  • sudo port install ImageMagick +wmf +jbig +jpeg2 +no_x11

However, the Quartz version is a little less mature and may have a few glitches in it, so we recommend starting out with the X11 version.

Mono

Currently, to build and run FieldWorks requires a special version of mono. So you will need to build mono from source.

Note that the MacPorts version of Mono is needed in order to build Mono from source.

Currently there is a problem with the atlas port (a dependency of py26-numpy) that conflicts with libLAPACK.dylib from /System/Library/Frameworks/. Until this is fixed, these two ports must be uninstalled when building mono.